|RTQUERY(8)||FreeBSD System Manager's Manual||RTQUERY(8)|
NAMErtquery — query routing daemons for their routing tables
|rtquery||[ -np1][ -w timeout][ -r addr][ -a secret] host ...|
|rtquery||[ -t op] host ...|
DESCRIPTIONThe rtquery utility is used to query a RIP network routing daemon, such as routed(8), for its routing table by sending a request or poll command. The routing information in any routing response packets returned is displayed numerically and symbolically.
The rtquery utility by default uses the request command. When the -p option is specified, rtquery uses the poll command, an undocumented extension to the RIP protocol supported by the commercial gated routing product. When querying gated, the poll command is preferred over the request command because the response is not subject to Split Horizon and/or Poisoned Reverse, and because some versions of gated do not answer the request command. The routed(8) utility does not answer the poll command, but recognizes requests coming from rtquery and so answers completely.
The rtquery utility is also used to turn tracing on or off in routed(8).
The following options are available:
- displays only the numeric network and host numbers instead of both numeric and symbolic.
- uses the poll command to request full routing information from gated. This is an undocumented extension RIP protocol supported only by gated.
- queries using RIP version 1 instead of RIP version 2.
- -w timeout
- changes the delay for an answer from each host. By default, each host is given 15 seconds to respond.
- -r addr
- asks about the route to destination addr.
- -a passwd=XXX
- -a md5_passwd=XXX|KeyID
- causes the query to be sent with the indicated cleartext or MD5 password.
- -t op
- changes tracing, where op is one of the following. Requests from processes not running with UID 0 or on distant networks are generally ignored by the daemon except for a message in the system log. gated is likely to ignore these debugging requests.
- turns tracing on into the specified file. That file must usually have been specified when the daemon was started or be the same as a fixed name, often /etc/routed.trace.
- increases the debugging level.
- turns off tracing.
- dumps the daemon's routing table to the current tracefile.
Routing Information Protocol, RIPv1, RFC1058.
Routing Information Protocol, RIPv2, RFC1723.
|June 1, 1996||FreeBSD|