|RRENUMD(8)||FreeBSD System Manager's Manual||RRENUMD(8)|
NAMErrenumd — router renumbering daemon
|rrenumd||[ -df][ -c conf_file | -s]|
DESCRIPTIONThe rrenumd utility transmits router renumbering request packets, to renumber the routers in the site network.
On KAME-based systems, router renumbering requests are received and processed by rtadvd(8). For other systems, refer to relevant documents.
The program will daemonize itself on invocation. It reads configuration information from standard input if -s is specified, or from conf_file if -c conf_file is specified.
The contents of configuration information are described in rrenumd.conf(5).
After successful configuration, rrenumd sends router renumbering messages periodically to configured destinations. Messages contain prefixes configured to be renumbered.
- Debug mode.
- Foreground mode. Do not become daemon.
- Script mode. Configuration information is obtained from standard input.
- -c conf_file
- Specify a configuration file where configuration information is kept.
EXIT STATUSThe program exits with 0 on success, and non-zero on failures.
STANDARDSMatt Crawford, Router Renumbering for IPv6, RFC, 2894, August 2000.
HISTORYThe rrenumd utility first appeared in KAME IPv6 protocol stack kit.
|September 7, 1998||FreeBSD|