|PAM_TACPLUS(8)||FreeBSD System Manager's Manual||PAM_TACPLUS(8)|
NAMEpam_tacplus — TACACS+ authentication PAM module
SYNOPSIS[ service-name] module-type control-flag pam_tacplus [ options]
DESCRIPTIONThe pam_tacplus module provides authentication services based upon the TACACS+ protocol for the PAM (Pluggable Authentication Module) framework.
The pam_tacplus module accepts these optional parameters:
- causes pam_tacplus to use a previously entered password instead of prompting for a new one. If no password has been entered then authentication fails.
- causes pam_tacplus to use a previously entered password, if one is available. If no password has been entered, pam_tacplus prompts for one as usual.
- causes echoing to be left on if pam_tacplus prompts for a password.
- conf= pathname
- specifies a non-standard location for the TACACS+ client configuration file (normally located in /etc/tacplus.conf).
- template_user= username
specifies a user whose
passwd(5) entry will be used as a template to create the session environment if the supplied username does not exist in local password database. The user will be authenticated with the supplied username and password, but his credentials to the system will be presented as the ones for
username, i.e., his login class, home directory, resource limits, etc. will be set to ones defined for
If this option is omitted, and there is no username in the system databases equal to the supplied one (as determined by call to getpwnam(3)), the authentication will fail.
- The standard TACACS+ client configuration file for pam_tacplus
HISTORYThe pam_tacplus module first appeared in FreeBSD 3.1.
AUTHORSThe pam_tacplus manual page was written by <abial@FreeBSD.org> and adapted to TACACS+ from RADIUS by <markm@FreeBSD.org>.
The pam_tacplus module was written by<jdp@FreeBSD.org>.
|August 2, 1999||FreeBSD|