|PAM_ECHO(8)||FreeBSD System Manager's Manual||PAM_ECHO(8)|
NAMEpam_echo — Echo PAM module
SYNOPSIS[ service-name] module-type control-flag pam_echo [ arguments]
DESCRIPTIONThe echo service module for PAM displays its arguments to the user, separated by spaces, using the current conversation function.
If the % character occurs anywhere in the arguments to pam_echo, it is assumed to introduce one of the following escape sequences:
- The name of the host on which the client runs ( PAM_RHOST).
- The current service name ( PAM_SERVICE).
- The name of the controlling tty ( PAM_TTY).
- The applicant's user name ( PAM_RUSER).
- The target account's user name ( PAM_USER).
Any other two-character sequence beginning with % expands to the character following the % character.
AUTHORSThe pam_echo module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
|February 6, 2003||FreeBSD|