|MLD6QUERY(8)||FreeBSD System Manager's Manual||MLD6QUERY(8)|
NAMEmld6query — send multicast listener query
|mld6query||[ -dr] intface [ maddr]|
DESCRIPTIONThe mld6query utility sends an IPv6 multicast listener discovery (MLD) query packet toward the specified multicast address, maddr, toward interface intface. If you omit maddr, linklocal all nodes multicast address(ff02::1) is used.
After sending a query, mld6query waits for replies for at most 10 seconds. If a reply is returned, mld6query prints it with its type and then waits for another reply.
This program is provided only for debugging. It is not necessary for normal use.
With -d, mld6query will transmit MLD done packet instead of MLD query packet. With -r, similarly, MLD report packet will be transmitted. -dr options are for debugging purposes only.
EXIT STATUSThe program exits with 0 on success, non-zero on failures.
HISTORYThe mld6query utility first appeared in WIDE/KAME IPv6 protocol stack kit.
BUGSThe mld6query utility does not take care of multicast addresses which have non link-local scope.
|May 17, 1998||FreeBSD|