|MKSNAP_FFS(8)||FreeBSD System Manager's Manual||MKSNAP_FFS(8)|
NAMEmksnap_ffs — take a file system snapshot
DESCRIPTIONThe mksnap_ffs utility creates a snapshot named snapshot_name.
The group ownership of the file is set to “
operator”; the owner of the file remains “
root”. The mode of the snapshot is set to be readable by the owner or members of the “
EXAMPLESCreate a snapshot of /usr/home file system and mount the snapshot elsewhere:
mksnap_ffs /usr/home/snapshot mdconfig -a -t vnode -o readonly -f /usr/home/snapshot mount -o ro /dev/md0 /mnt/
HISTORYThe mksnap_ffs utility first appeared in FreeBSD 5.0.
CAVEATSThe disk full situation is not handled gracefully and may lead to a system panic when no free blocks are found.
Every filesystem can have only up to 20 active snapshots. When this limit is reached, attempting to create more snapshots fails with ENOSPC, and mksnap_ffs reports that it is “out of space”.
|February 14, 2011||FreeBSD|