|MAKEMAP(8)||FreeBSD System Manager's Manual||MAKEMAP(8)|
NAMEmakemap - create database maps for sendmail
SYNOPSISmakemap [ -C file] [ -N] [ -c cachesize] [ -d] [ -D commentchar] [ -e] [ -f] [ -l] [ -o] [ -r] [ -s] [ -t delim] [ -u] [ -v] maptype mapnam
DESCRIPTIONMakemap creates the database maps used by the keyed map lookups in sendmail(8). It reads input from the standard input and outputs them to the indicated mapname.
Depending on how it is compiled, makemap handles up to three different database formats, selected using the maptype parameter. They may be
- DBM format maps. This requires the ndbm(3) library.
- B-Tree format maps. This requires the new Berkeley DB library.
- Hash format maps. This also requires the Berkeley DB library.
In all cases, makemap reads lines from the standard input consisting of two words separated by white space. The first is the database key, the second is the value. The value may contain ``% n'' strings to indicate parameter substitution. Literal percents should be doubled (``%%''). Blank lines and lines beginning with ``#'' are ignored.
Notice: do not use makemap to create the aliases data base, but newaliases which puts a special token into the data base that is required by sendmail.
If the TrustedUser option is set in the sendmail configuration file and makemap is invoked as root, the generated files will be owned by the specified TrustedUser.
- Use the specified sendmail configuration file for looking up the TrustedUser option.
- Include the null byte that terminates strings in the map. This must match the -N flag in the sendmail.cf ``K'' line.
- Use the specified hash and B-Tree cache size.
- Use to specify the character to use to indicate a comment (which is ignored) instead of the default of '#'.
- Allow duplicate keys in the map. This is only allowed on B-Tree format maps. If two identical keys are read, they will both be inserted into the map.
- Allow empty value (right hand side).
- Normally all upper case letters in the key are folded to lower case. This flag disables that behaviour. This is intended to mesh with the -f flag in the K line in sendmail.cf. The value is never case folded.
- List supported map types.
- Append to an old file. This allows you to augment an existing file.
- Allow replacement of existing keys. Normally makemap complains if you repeat a key, and does not do the insert.
- Ignore safety checks on maps being created. This includes checking for hard or symbolic links in world writable directories.
- Use the specified delimiter instead of white space (also for dumping a map).
- dump (unmap) the content of the database to standard output.
- Verbosely print what it is doing.
SEE ALSOsendmail(8), newaliases(1)
HISTORYThe makemap command appeared in 4.4BSD.
|$Date: 2013-11-22 20:51:52 $|