|KGMON(8)||FreeBSD System Manager's Manual||KGMON(8)|
NAMEkgmon — generate a dump of the operating system's profile buffers
|kgmon||[ -Bbhpr][ -M core][ -N system]|
DESCRIPTIONThe kgmon utility is used when profiling the operating system. When no arguments are supplied, kgmon indicates the state of operating system profiling as running, off, or not configured. (see config(8)) If the -p flag is specified, kgmon extracts profile data from the operating system and produces a gmon.out file suitable for later analysis by gprof(1).
The options are as follows:
- Resume the collection of high resolution profile data.
- Resume the collection of low resolution profile data.
- Stop the collection of profile data.
- Dump the contents of the profile buffers into a gmon.out file.
- Reset all the profile buffers. If the -p flag is also specified, the gmon.out file is generated before the buffers are reset.
- Extract values associated with the name list from the specified core instead of the default /dev/kmem.
- Extract the name list from the specified system instead of the default /boot/kernel/kernel.
If neither -B nor -b nor -h is specified, the state of profiling collection remains unchanged. For example, if the -p flag is specified and profile data is being collected, profiling will be momentarily suspended, the operating system profile buffers will be dumped, and profiling will be immediately resumed.
The profile buffers should be reset when the resolution of the profile data is changed.
- the default system
- the default memory
DIAGNOSTICSUsers with only read permission on /dev/kmem cannot change the state of profiling collection. They can get a gmon.out file with the warning that the data may be inconsistent if profiling is in progress.
HISTORYThe kgmon utility appeared in 4.2BSD.
|June 6, 1993||FreeBSD|