|IPPOOL(8)||FreeBSD System Manager's Manual||IPPOOL(8)|
NAMEippool - user interface to the IPFilter pools
SYNOPSISippool -a [-dnv] [-m <name>] [-o <role>] [-t <type>] [-T ttl] -i <ipaddr>[/<netmask>]
DESCRIPTIONIppool is used to manage information stored in the IP pools subsystem of IPFilter. Configuration file information may be parsed and loaded into the kernel, currently configured pools removed or changed as well as inspected.
The command line options used are broken into two sections: the global options and the instance specific options.
- Toggle debugging of processing the configuration file.
- This flag (no-change) prevents ippool from actually making any ioctl calls or doing anything which would alter the currently running kernel.
- Turn verbose mode on.
- Add a new data node to an existing pool in the kernel.
- Add a new (empty) pool to the kernel.
- -f <file>
- Read in IP pool configuration information from the file and load it into the kernel.
- Flush loaded pools from the kernel.
- Display a list of pools currently loaded into the kernel.
- Remove an existing data node from a pool in the kernel.
- Remove an existing pool from within the kernel.
- Display IP pool statistical information.
- -i <ipaddr>[/<netmask>]
- Sets the IP address for the operation being undertaken with an all-one's mask or, optionally, a specific netmask given in either the dotted-quad notation or a single integer.
- -m <name>
- Sets the pool name for the current operation.
- -M <core>
- Specify an alternative path to /dev/kmem to retrieve statistical information from.
- -N <namelist>
- Specify an alternative path to lookup symbol name information from when retrieving statistical information.
- -o <role>
- Sets the role with which this pool is to be used. Currently only ipf, auth and count are accepted as arguments to this option.
- -S <seed>
- Sets the hashing seed to the number specified. Only for use with hash type pools.
- -t <type>
- Sets the type of pool being defined. Myst be one of tree, hash, group-map.
- -T <ttl>
- Sets the expiration of the node being added. The timeout is expressed as a number of seconds. tree, hash, group-map.
- When parsing a configuration file, rather than load new pool data into the kernel, unload it.