|IPFWPCAP(8)||FreeBSD System Manager's Manual||IPFWPCAP(8)|
NAMEipfwpcap — copy diverted packets to a file in tcpdump format
|ipfwpcap||[ -dr][ -b maxbytes][ -p maxpkts][ -P pidfile] portnum dumpfile|
DESCRIPTIONThe ipfwpcap utility is used to copy diverted packets to a file in tcpdump(1) format. The interesting packets are diverted by ipfw(8) to a port on which ipfwpcap listens. The packets are then dropped unless -r is used.
The options are as follows:
- Turns on extra debugging messages.
- Writes packets back to the divert(4) socket.
- Indicates that it is okay to quit if maxbytes or maxpkts are reached. Diverted packets will silently disappear if nothing is listening on the divert(4) socket.
- -b maxbytes
- Stop dumping after maxbytes bytes.
- -p maxpkts
- Stop dumping after maxpkt packets.
- -P pidfile
- File to store PID number in. Default is /var/run/ipwfpcap.portnr.pid.
The portnum argument specifies which divert(4) socket port to listen on. The dumpfile argument is the path to the file to write captured packets to. Specify ‘ -’ to write to stdout.
EXIT STATUSThe ipfwpcap utility exits 0 on success, and >0 if an error occurs.
ipfwpcap -r 8091 divt.log &
Starts ipfwpcap as a background job listening to port 8091 and reflecting the packets back to the socket.
ipfw add 2864 divert 8091 ip from 192.0.2.101
HISTORYThe ipfwpcap utility first appeared in FreeBSD 7.0.
AUTHORSipfwpcap was written by <firstname.lastname@example.org>. This manual page was written by <zeising@FreeBSD.org>.
|May 22, 2006||FreeBSD|