|HOSTAPD_CLI(8)||FreeBSD System Manager's Manual||HOSTAPD_CLI(8)|
NAMEhostapd_cli — text-based frontend program for interacting with hostapd(8)
DESCRIPTIONThe hostapd_cli utility is a text-based frontend program for interacting with hostapd(8). It is used to query the current status.
The hostapd_cli utility can show the current authentication status, dot11 and dot1x MIBs, etc.
The hostapd_cli utility supports two modes: interactive and command line. Both modes share the same command set.
Interactive mode is started when hostapd_cli is executed without any parameters on the command line. Commands are then entered from the controlling terminal in response to the hostapd_cli prompt. In command line mode, the same commands are entered as command line arguments.
COMMANDSThe following commands may be supplied on the command line or at a prompt when operating interactively.
- Report MIB variables (dot1x, dot11) for the current interface.
- sta addr
- Report the MIB variables for the associated station with MAC address addr.
- Report the MIB variables for all associated stations.
- Show usage help.
- interface [ ifname]
- Show available interfaces and/or set the current interface when multiple are available.
- level debug_level
- Change the debugging level in hostapd(8). Larger numbers generate more messages.
- Display the full license for hostapd_cli.
- Exit hostapd_cli.
HISTORYThe hostapd_cli utility first appeared in FreeBSD 6.0.
AUTHORSThe hostapd_cli utility was written by <firstname.lastname@example.org>. This manual page is derived from the README file included in the hostapd distribution.
|June 16, 2005||FreeBSD|