|FIXMOUNT(8)||FreeBSD System Manager's Manual||FIXMOUNT(8)|
NAMEfixmount — fix remote mount entries
|fixmount||[ -adervq][ -h name] host ...|
DESCRIPTIONThe fixmount utility is a variant of showmount(8) that can delete bogus mount entries in remote mountd(8) daemons. The actions specified by the options are performed for each host in turn.
- -a, -d, -e
- These options work as in showmount(8) except that only entries pertaining to the local host are printed.
- Removes those remote mount entries on host that do not correspond to current mounts, i.e., which are left-over from a crash or are the result of improper mount protocol. The actuality of mounts is verified using the entries in /etc/mtab.
- Verify remote mounts. Similar to -r except that only a notification message is printed for each bogus entry found. The remote mount table is not changed.
- Issues a command to the remote mountd declaring that all of its file systems have been unmounted. This should be used with caution, as it removes all remote mount entries pertaining to the local system, whether or not any file systems are still mounted locally.
Be quiet. Suppresses error messages due to timeouts and “
Program not registered”, i.e., due to remote hosts not supporting RPC or not running mountd(8).
- -h name
Pretend the local hostname is
name. This is useful after the local hostname has been changed and rmtab entries using the old name remain on a remote machine. Unfortunately, most mountd's will not be able to successfully handle removal of such entries, so this option is useful in combination with
This option also saves time as comparisons of remotely recorded and local hostnames by address are avoided.
- List of current mounts.
- Backup file for remote mount entries on NFS server.
SEE ALSOmtab(5), rmtab(5), mountd(8), showmount(8)
“am-utils” info(1) entry.
Erez Zadok, Linux NFS and Automounter Administration, Sybex, 2001, ISBN 0-7821-2739-8.
Amd - The 4.4 BSD Automounter.
HISTORYThe fixmount utility appeared in FreeBSD 3.0.
AUTHORS<email@example.com>, Department of Computing, Imperial College, London, UK.
<firstname.lastname@example.org>, Department of Computer Science, Columbia University, New York, USA.
am-utils are listed in the AUTHORS file distributed with am-utils.
<email@example.com>, Computer Science Department, Stony Brook University, Stony Brook, New York, USA.
Other authors and contributors to am-utils are listed in the AUTHORS file distributed with am-utils.
BUGSNo attempt is made to verify the information in /etc/mtab itself.
Since swap file mounts are not recorded in /etc/mtab, a heuristic specific to SunOS is used to determine whether such a mount is actual (replacing the string “
swap” with “
root” and verifying the resulting path).
Symbolic links on the server will cause the path in the remote entry to differ from the one in /etc/mtab. To catch those cases, a file system is also deemed mounted if its local mount point is identical to the remote entry. I.e., on a SunOS diskless client, server:/export/share/sunos.4.1.1 is actually /usr/share. Since the local mount point is /usr/share as well this will be handled correctly.
There is no way to clear a stale entry in a remote mountd(8) after the local hostname (or whatever reverse name resolution returns for it) has been changed. To take care of these cases, the remote /etc/rmtab file has to be edited and mountd(8) restarted.
The RPC timeouts for mountd(8) calls can only be changed by recompiling. The defaults are 2 seconds for client handle creation and 5 seconds for RPC calls.
|January 2, 2006||FreeBSD|