|FFSINFO(8)||FreeBSD System Manager's Manual||FFSINFO(8)|
NAMEffsinfo — dump all meta information of an existing ufs file system
|ffsinfo||[ -g cylinder_group][ -i inode][ -l level][ -o outfile] special | file|
DESCRIPTIONThe ffsinfo utility extends the dumpfs(8) utility.
The output is appended to the file outfile. Also expect the output file to be rather large. Up to 2 percent of the size of the specified file system is not uncommon.
The following options are available:
- -g cylinder_group
- This restricts the dump to information about this cylinder group only. Here 0 means the first cylinder group and -1 the last one.
- -i inode
- This restricts the dump to information about this particular inode only. Here the minimum acceptable inode is 2. If this option is omitted but a cylinder group is defined then only inodes within that cylinder group are dumped.
- -l level
The level of detail which will be dumped. This value defaults to
255 and is the “bitwise or” of the following table:
- initial superblock
- superblock copies in each cylinder group
- cylinder group summary in initial cylinder group
- cylinder group information
- inode allocation bitmap
- fragment allocation bitmap
- cluster maps and summary
- inode information
- indirect block dump
- -o outfile
- This sets the output filename where the dump is written to, and must be specified. If - is provided, output will be sent to stdout.
ffsinfo -o /var/tmp/ffsinfo -l 1023 /dev/vinum/testvol
will dump /dev/vinum/testvol to /var/tmp/ffsinfo with all available information.
HISTORYThe ffsinfo utility first appeared in FreeBSD 4.4.
AUTHORS<chm@FreeBSD.org> <tomsoft@FreeBSD.org> <growfs@Tomsoft.COM>
BUGSSnapshots are handled like plain files. They should get their own level to provide for independent control of the amount of what gets dumped. It probably also makes sense to some extend to dump the snapshot as a file system.
|September 8, 2000||FreeBSD|