|EDITMAP(8)||FreeBSD System Manager's Manual||EDITMAP(8)|
NAMEeditmap - query and edit single records in database maps for sendmail
SYNOPSISeditmap [ -C file] [ -N] [ -f] [ -q|-u|-x] maptype mapname key [ "value ..." ]
DESCRIPTIONEditmap queries or edits one record in database maps used by the keyed map lookups in sendmail(8). Arguments are passed on the command line and output (for queries) is directed to standard output.
Depending on how it is compiled, editmap handles up to three different database formats, selected using the maptype parameter. They may be
- DBM format maps. This requires the ndbm(3) library.
- B-Tree format maps. This requires the new Berkeley DB library.
- Hash format maps. This also requires the Berkeley DB library.
If the TrustedUser option is set in the sendmail configuration file and editmap is invoked as root, the generated files will be owned by the specified TrustedUser.
- Use the specified sendmail configuration file for looking up the TrustedUser option.
- Include the null byte that terminates strings in the map (for alias maps).
- Normally all upper case letters in the key are folded to lower case. This flag disables that behaviour. This is intended to mesh with the -f flag in the K line in sendmail.cf. The value is never case folded.
- Query the map for the specified key. If found, print value to standard output and exit with 0. If not found then print an error message to stdout and exit with EX_UNAVAILABLE.
- Update the record for key with value or inserts a new record if one doesn't exist. Exits with 0 on success or EX_IOERR on failure.
- Deletes the specific key from the map. Exits with 0 on success or EX_IOERR on failure.
SEE ALSOsendmail(8), makemap(8)
HISTORYThe editmap command has no history.
|$Date: 2013-11-22 20:51:26 $|