|DUMPON(8)||FreeBSD System Manager's Manual||DUMPON(8)|
NAMEdumpon — specify a device for crash dumps
|dumpon||[ -v] special_file|
|dumpon||[ -v] off|
|dumpon||[ -v] -l|
DESCRIPTIONThe dumpon utility is used to specify a device where the kernel can save a crash dump in the case of a panic.
Calls to dumpon normally occur from the system multi-user initialization file /etc/rc, controlled by the “dumpdev” variable in the boot time configuration file /etc/rc.conf.
The default type of kernel crash dump is the mini crash dump. Mini crash dumps hold only memory pages in use by the kernel. Alternatively, full memory dumps can be enabled by setting the debug.minidump sysctl(8) variable to 0.
For systems using full memory dumps, the size of the specified dump device must be at least the size of physical memory. Even though an additional 64 kB header is added to the dump, the BIOS for a platform typically holds back some memory, so it is not usually necessary to size the dump device larger than the actual amount of RAM available in the machine. Also, when using full memory dumps, the dumpon utility will refuse to enable a dump device which is smaller than the total amount of physical memory as reported by the hw.physmem sysctl(8) variable.
The -l flag causes dumpon to print the current dump device or _PATH_DEVNULL ("/dev/null") if no device is configured.
The -v flag causes dumpon to be verbose about its activity.
IMPLEMENTATION NOTESSince a panic(9) condition may occur in a situation where the kernel cannot trust its internal representation of the state of any given file system, one of the system swap devices, and not a device containing a file system, should be used as the dump device.
The dumpon utility operates by opening special_file and making a DIOCSKERNELDUMP ioctl(2) request on it to save kernel crash dumps. If special_file is the text string: “
off”, dumpon performs a DIOCSKERNELDUMP ioctl(2) on /dev/null and thus instructs the kernel not to save crash dumps.
- standard swap areas
- boot-time system configuration
HISTORYThe dumpon utility appeared in FreeBSD 2.1.
BUGSBecause the file system layer is already dead by the time a crash dump is taken, it is not possible to send crash dumps directly to a file.
|April 29, 2013||FreeBSD|