|DUMPFS(8)||FreeBSD System Manager's Manual||DUMPFS(8)|
NAMEdumpfs — dump UFS file system information
|dumpfs||[ -f][ -l][ -m] filesys | device|
DESCRIPTIONThe dumpfs utility prints out the UFS super block and cylinder group information for the file system or special device specified, unless the -f, -l or -m flag is specified. The listing is very long and detailed. This command is useful mostly for finding out certain file system information such as the file system block size and minimum free space percentage.
If -f is specified, a sorted list of all free fragments and free fragment ranges, as represented in cylinder group block free lists, is printed. If the flag is specified twice, contiguous free fragments are not collapsed into ranges and instead printed in a simple list. Fragment numbers may be converted to raw byte offsets by multiplying by the fragment size, which may be useful when recovering deleted data.
If -l is specified, the pathname to the file system's container derived from its unique identifier is printed.
If -m is specified, a newfs(8) command is printed that can be used to generate a new file system with equivalent settings. Please note that newfs(8) options -E, -R, -S, and -T are not handled and -p is not useful in this case so is omitted. Newfs(8) options -n and -r are neither checked for nor output but should be. The -r flag is needed if the filesystem uses gjournal(8).
HISTORYThe dumpfs utility appeared in 4.2BSD.
|May 16, 2013||FreeBSD|