|DELAY.4TH(8)||FreeBSD System Manager's Manual||DELAY.4TH(8)|
NAMEdelay.4th — FreeBSD debugging boot module
DESCRIPTIONThe file that goes by the name of delay.4th is a set of commands designed to add debugging capabilities to loader(8). The commands of delay.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in delay.4th, it must be included through the command:
This line is present in /boot/beastie.4th file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
Executes the [string] procedure stored in the
delay_command environment variable after
If the optional delay_showdots environment variable is set, a continuous series of dots is printed.
During the duration, the user can either press Ctrl-C (or Esc) to abort or ENTER to proceed immediately.
The environment variables that effect its behavior are:
- The command to be executed by delay_execute.
- The duration (in seconds) to delay before executing delay_command.
- If set, will cause delay_execute to print a continuous series of dots during the delay duration.
EXAMPLESIntroducing a 5-second delay before including another file from /boot/loader.rc:
include /boot/delay.4th set delay_command="include /boot/other.4th" set delay_showdots set loader_delay=5 delay_execute
HISTORYThe delay.4th set of commands first appeared in FreeBSD 9.0.
AUTHORSThe delay.4th set of commands was written by <dteske@FreeBSD.org>.
|May 18, 2011||FreeBSD|