|COLOR.4TH(8)||FreeBSD System Manager's Manual||COLOR.4TH(8)|
NAMEcolor.4th — FreeBSD color-detection boot module
DESCRIPTIONThe file that goes by the name of color.4th is a set of commands designed to simplify color logic. The commands of color.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in color.4th, it must be included through the command:
This line is present in /boot/loader.4th file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
- Returns FALSE if the loader_color environment variable is set to “NO” (case-insensitive) or “0”. Otherwise returns TRUE (unless booting serial).
The environment variables that effect its behavior are:
- If set to “NO” (case-insensitive) or “0”, causes loader_color? to return FALSE, indicating to many modules that color should not be used.
EXAMPLESStandard i386 /boot/loader.rc:
Use color where applicable:
HISTORYThe color.4th set of commands first appeared in FreeBSD 9.0.
AUTHORSThe color.4th set of commands was written by <dteske@FreeBSD.org>.
|August 6, 2013||FreeBSD|