|CHROOT(8)||FreeBSD System Manager's Manual||CHROOT(8)|
NAMEchroot — change root directory
|chroot||[ -u user][ -g group][ -G group,group,...] newroot [ command]|
DESCRIPTIONThe chroot utility changes its current and root directories to the supplied directory newroot and then exec's command, if supplied, or an interactive copy of the user's login shell.
If the -u, -g or -G options are given, the user, group and group list of the process are set to these values after the chroot has taken place.
ENVIRONMENTThe following environment variable is referenced by chroot:
- If set, the string specified by SHELL is interpreted as the name of the shell to exec. If the variable SHELL is not set, /bin/sh is used.
HISTORYThe chroot utility first appeared in 4.4BSD.
|June 7, 2003||FreeBSD|