|CHECK-PASSWORD.4TH(8)||FreeBSD System Manager's Manual||CHECK-PASSWORD.4TH(8)|
NAMEcheck-password.4th — FreeBSD password-checking boot module
DESCRIPTIONThe file that goes by the name of check-password.4th is a set of commands designed to either prevent booting or prevent modification of boot options without an appropriately configured password. The commands of check-password.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in check-password.4th, it must be included through the command:
This line is present in /boot/loader.4th file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
Dual-purpose function that can either protect the interactive boot menu or prevent boot without password (separately).
First checks bootlock_password and if-set, the user cannot continue until the correct password is entered.
Next checks password and if-set, tries to autoboot and only prompts for password on failure or user-interrupt. See loader.conf(5) for additional information.
The environment variables that effect its behavior are:
- Sets the bootlock password (up to 16 characters long) that is required by check-password to be entered before the system is allowed to boot.
- Sets the password (up to 16 characters long) that is required by check-password before the user is allowed to visit the boot menu.
EXAMPLESStandard i386 /boot/loader.rc:
include /boot/loader.4th check-password
Set a password in loader.conf(5) to prevent modification of boot options:
Set a password in loader.conf(5) to prevent booting without password:
HISTORYThe check-password.4th set of commands first appeared in FreeBSD 9.0.
AUTHORSThe check-password.4th set of commands was written by <dteske@FreeBSD.org>.
|December 10, 2012||FreeBSD|