|BRAND.4TH(8)||FreeBSD System Manager's Manual||BRAND.4TH(8)|
NAMEbrand.4th — FreeBSD ASCII art boot module
DESCRIPTIONThe file that goes by the name of brand.4th is a set of commands designed to draw the ASCII art BSD brand above the boot loader menu. The commands of brand.4th by themselves are not enough for most uses. Please refer to the examples below for the most common situations, and to loader(8) for additional commands.
Before using any of the commands provided in brand.4th, it must be included through the command:
This line is present in the default /boot/menu.rc file, so it is not needed (and should not be re-issued) in a normal setup.
The commands provided by it are:
Draws the BSD brand.
The brand that is drawn is configured by setting the loader_brand variable in loader.conf(5) to one of “
fbsd” (the default) or “
The position of the logo can be configured by setting the loader_brand_x and loader_brand_y variables in loader.conf(5). The default values are 2 (x) and 1 (y).
The environment variables that effect its behavior are:
Selects the desired brand in the beastie boot menu. Possible values are: “
fbsd” (default) or “
- Sets the desired column position of the brand. Default is 2.
- Sets the desired row position of the brand. Default is 1.
EXAMPLESSet FreeBSD brand in loader.conf(5):
HISTORYThe brand.4th set of commands first appeared in FreeBSD 9.0.
AUTHORSThe brand.4th set of commands was written by <dteske@FreeBSD.org>.
|May 18, 2011||FreeBSD|