|BOOTPTEST(8)||FreeBSD System Manager's Manual||BOOTPTEST(8)|
NAMEbootptest — send BOOTP queries and print responses
|bootptest||[ -f bootfile][ -h][ -m magic_number] server-name [ template-file]|
DESCRIPTIONThe bootptest utility sends BOOTP requests to the host specified as server-name at one-second intervals until either a response is received, or until ten requests have gone unanswered. After a response is received, bootptest will wait one more second listening for additional responses.
- -f bootfile
- Fill in the boot file field of the request with bootfile.
- Use the hardware (Ethernet) address to identify the client. By default, the IP address is copied into the request indicating that this client already knows its IP address.
- -m magic_number
- Initialize the first word of the vendor options field with magic_number.
A template-file may be specified, in which case bootptest uses the (binary) contents of this file to initialize the options area of the request packet.
BOOTSTRAP PROTOCOL (BOOTP), RFC951.
BOOTP Vendor Information Extensions, RFC1048.
AUTHORSThe bootptest utility is a combination of original and derived works. The main program module ( bootptest.c) is original work by <firstname.lastname@example.org>. The packet printing module ( print-bootp.c) is a slightly modified version of a file from the BSD tcpdump(1) program.
This program includes software developed by the University of California, Lawrence Berkeley Laboratory and its contributors. (See the copyright notice in print-bootp.c.)
|June 10, 1993||FreeBSD|