EN JA
OPERATOR(7)
OPERATOR(7) FreeBSD Miscellaneous Information Manual OPERATOR(7)

NAME

operatorC and C++ operator precedence and order of evaluation

DESCRIPTION

Operator Associativity
-------- -------------
() [] -> . left to right
! ~ ++ -- - (type) * & sizeof new delete right to left
->* .* left to right
* / % left to right
+ - left to right
<< >> left to right
< <= > >= left to right
== != left to right
& left to right
^ left to right
| left to right
&& left to right
|| left to right
?: right to left
= += -= *= /= %= <<= >>= &= ^= |= throw right to left
?: (C++, third operand) right to left
, left to right

FILES

/usr/share/misc/operator
April 8, 2009 FreeBSD