|TMPFS(5)||FreeBSD File Formats Manual||TMPFS(5)|
NAMEtmpfs — efficient memory file system
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe tmpfs driver will permit the FreeBSD kernel to access tmpfs file systems.
OPTIONSThe following options are available when mounting tmpfs file systems:
- Specifies the group ID of the root inode of the file system. Defaults to the mount point's GID.
- Specifies the user ID of the root inode of the file system. Defaults to the mount point's UID.
- Specifies the mode (in octal notation) of the root inode of the file system. Defaults to the mount point's mode.
- Specifies the maximum number of nodes available to the file system. If not specified, the file system chooses a reasonable maximum based on the file system size, which can be limited with the size option.
- Specifies the total file system size in bytes. If zero (the default) or a value larger than SIZE_MAX - PAGE_SIZE is given, the available amount of memory (including main memory and swap space) will be used.
- Specifies the maximum file size in bytes. Defaults to the maximum possible value.
EXAMPLESTo mount a tmpfs memory file system:
mount -t tmpfs tmpfs /tmp
HISTORYThe tmpfs driver first appeared in FreeBSD 7.0.
AUTHORSThe tmpfs kernel implementation was written by <jmmv@NetBSD.org> as a Google SoC project.
NetBSD to FreeBSD.and others ported it from
This manual page was written by<delphij@FreeBSD.org>.
BUGSSome file system mount time options may not be well-supported.
|April 23, 2012||FreeBSD|