|SYSCTL.CONF(5)||FreeBSD File Formats Manual||SYSCTL.CONF(5)|
NAMEsysctl.conf — kernel state defaults
DESCRIPTIONThe /etc/sysctl.conf file is read in when the system goes into multi-user mode to set default settings for the kernel. The /etc/sysctl.conf is in the format of the sysctl(8) command, i.e.
Comments are denoted by a “#” at the beginning of a line. Comments can also exist at the end of a line, as seen in the EXAMPLES section, below.
- Initial settings for sysctl(8).
EXAMPLESTo turn off logging of programs that exit due to fatal signals you may use a configuration like
# Configure logging. kern.logsigexit=0 # Do not log fatal signal exits (e.g. sig 11)
HISTORYThe sysctl.conf file appeared in FreeBSD 4.0.
BUGSIf loadable kernel modules are used to introduce additional kernel functionality and sysctls to manage that functionality, sysctl.conf may be processed too early in the boot process to set those sysctls. For example, sysctls to manage the linux emulator cannot be set in sysctl.conf if the linux emulator is loaded as a module rather than compiled into the kernel.
|December 30, 1999||FreeBSD|