EN JA
SRC.CONF(5)
SRC.CONF(5) FreeBSD File Formats Manual SRC.CONF(5)

NAME

src.confsource build options

DESCRIPTION

The src.conf file contains settings that will apply to every build involving the FreeBSD source tree; see build(7).

The src.conf file uses the standard makefile syntax. However, src.conf should not specify any dependencies to make(1). Instead, src.conf is to set make(1) variables that control the aspects of how the system builds.

The default location of src.conf is /etc/src.conf, though an alternative location can be specified in the make(1) variable SRCCONF. Overriding the location of src.conf may be necessary if the system-wide settings are not suitable for a particular build. For instance, setting SRCCONF to /dev/null effectively resets all build controls to their defaults.

The only purpose of src.conf is to control the compilation of the FreeBSD source code, which is usually located in /usr/src. As a rule, the system administrator creates src.conf when the values of certain control variables need to be changed from their defaults.

In addition, control variables can be specified for a particular build via the -D option of make(1) or in its environment; see environ(7).

The values of variables are ignored regardless of their setting; even if they would be set to “ FALSE” or “ NO”. Just the existence of an option will cause it to be honoured by make(1).

The following list provides a name and short description for variables that can be used for source builds.

WITHOUT_ACCT
Set to not build process accounting tools such as accton(8) and sa(8).
WITHOUT_ACPI
Set to not build acpiconf(8), acpidump(8) and related programs.
WITHOUT_AMD
Set to not build amd(8), and related programs.
WITHOUT_APM
Set to not build apm(8), apmd(8) and related programs.
WITHOUT_ARM_EABI
Set the ARM ABI to OABI.
WITHOUT_ASSERT_DEBUG
Set to compile programs and libraries without the assert(3) checks.
WITHOUT_AT
Set to not build at(1) and related utilities.
WITHOUT_ATM
Set to not build programs and libraries related to ATM networking.
WITHOUT_AUDIT
Set to not build audit support into system programs.
WITHOUT_AUTHPF
Set to not build authpf(8).
WITHOUT_BINUTILS
Set to not install binutils (as, c++-filt, gconv, ld, nm, objcopy, objdump, readelf, size and strip).
The option does not generally work for build targets, unless some alternative toolchain is enabled.
WITHOUT_BLUETOOTH
Set to not build Bluetooth related kernel modules, programs and libraries.
WITHOUT_BMAKE
Set to not build and install the portable BSD make (bmake) as make(1) instead of the traditional FreeBSD make. This build option is temporary. It allows developers to switch to the traditional FreeBSD make in order to work out any remaining kinks or issues. This option will be removed in due time.
WITHOUT_BOOT
Set to not build the boot blocks and loader.
WITHOUT_BSD_CPIO
Set to not build the BSD licensed version of cpio based on libarchive(3).
WITH_BSD_GREP
Install BSD-licensed grep as '[ef]grep' instead of GNU grep.
WITHOUT_BSNMP
Set to not build or install bsnmpd(1) and related libraries and data files.
WITHOUT_BZIP2
Set to not build contributed bzip2 software as a part of the base system.
The option has no effect yet.
When set, it also enforces the following options:

  • WITHOUT_BZIP2_SUPPORT
WITHOUT_BZIP2_SUPPORT
Set to build some programs without optional bzip2 support.
WITHOUT_CALENDAR
Set to not build calendar(1).
WITHOUT_CAPSICUM
Set to not build Capsicum support into system programs.
WITHOUT_CDDL
Set to not build code licensed under Sun's CDDL. When set, it also enforces the following options:

  • WITHOUT_CTF
  • WITHOUT_ZFS
WITHOUT_CLANG
Set to not build the Clang C/C++ compiler.

It is a default setting on arm/armeb, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32 and sparc64/sparc64. When set, it also enforces the following options:

  • WITHOUT_CLANG_EXTRAS
  • WITHOUT_CLANG_FULL
WITH_CLANG
Set to build the Clang C/C++ compiler.

It is a default setting on amd64/amd64, arm/arm, arm/armv6, i386/i386, pc98/i386, powerpc/powerpc and powerpc/powerpc64.

WITH_CLANG_EXTRAS
Set to build additional clang and llvm tools, such as bugpoint.
WITHOUT_CLANG_FULL
Set to avoid building the ARCMigrate, Rewriter and StaticAnalyzer components of the Clang C/C++ compiler.

It is a default setting on arm/arm, arm/armeb, arm/armv6, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32 and sparc64/sparc64.

WITH_CLANG_FULL
Set to build the ARCMigrate, Rewriter and StaticAnalyzer components of the Clang C/C++ compiler.

It is a default setting on amd64/amd64, i386/i386, pc98/i386, powerpc/powerpc and powerpc/powerpc64.

WITHOUT_CLANG_IS_CC
Set to install the GCC compiler as /usr/bin/cc, /usr/bin/c++ and /usr/bin/cpp.

It is a default setting on arm/armeb, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32, powerpc/powerpc, powerpc/powerpc64 and sparc64/sparc64. When set, it also enforces the following options:

  • WITHOUT_LLDB
WITH_CLANG_IS_CC
Set to install the Clang C/C++ compiler as /usr/bin/cc, /usr/bin/c++ and /usr/bin/cpp.

It is a default setting on amd64/amd64, arm/arm, arm/armv6, i386/i386 and pc98/i386.

WITHOUT_CPP
Set to not build cpp(1).
WITHOUT_CROSS_COMPILER
Set to not build a cross compiler in the cross-tools stage of buildworld, buildkernel, etc.
WITHOUT_CRYPT
Set to not build any crypto code. When set, it also enforces the following options:

  • WITHOUT_KERBEROS
  • WITHOUT_KERBEROS_SUPPORT
  • WITHOUT_OPENSSH
  • WITHOUT_OPENSSL

When set, the following options are also in effect:

WITHOUT_GSSAPI
(unless WITH_GSSAPI is set explicitly)
WITH_CTF
Set to compile with CTF (Compact C Type Format) data. CTF data encapsulates a reduced form of debugging information similar to DWARF and the venerable stabs and is required for DTrace.
WITHOUT_CTM
Set to not build ctm(1) and related utilities.
WITHOUT_CXX
Set to not build g++(1) and related libraries. It will also prevent building of gperf(1) and devd(8). When set, it also enforces the following options:

  • WITHOUT_CLANG
  • WITHOUT_CLANG_EXTRAS
  • WITHOUT_CLANG_FULL
  • WITHOUT_GROFF
WITH_DEBUG_FILES
Set to strip debug info into a separate file for each executable binary and shared library. The debug files will be placed in a subdirectory of /usr/lib/debug and are located automatically by gdb(1).
WITHOUT_DICT
Set to not build the Webster dictionary files.
WITHOUT_DYNAMICROOT
Set this if you do not want to link /bin and /sbin dynamically.
WITHOUT_ED_CRYPTO
Set to build ed(1) without support for encryption/decryption.
WITHOUT_EXAMPLES
Set to avoid installing examples to /usr/share/examples/.
WITHOUT_FDT
Set to not build Flattened Device Tree support as part of the base system. This includes the device tree compiler (dtc) and libfdt support library.

It is a default setting on amd64/amd64, i386/i386, ia64/ia64, pc98/i386 and sparc64/sparc64.

WITH_FDT
Set to build Flattened Device Tree support as part of the base system. This includes the device tree compiler (dtc) and libfdt support library.

It is a default setting on arm/arm, arm/armeb, arm/armv6, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32, powerpc/powerpc and powerpc/powerpc64.

WITHOUT_FLOPPY
Set to not build or install programs for operating floppy disk driver.
WITHOUT_FMTREE
Set to not build and install /usr/sbin/fmtree.
WITHOUT_FORMAT_EXTENSIONS
Set to not enable -fformat-extensions when compiling the kernel. Also disables all format checking.
WITHOUT_FORTH
Set to build bootloaders without Forth support.
WITHOUT_FP_LIBC
Set to build libc without floating-point support.
WITHOUT_FREEBSD_UPDATE
Set to not build freebsd-update(8).
WITHOUT_GAMES
Set to not build games.
WITHOUT_GCC
Set to not build and install gcc and g++.

It is a default setting on amd64/amd64, arm/arm, arm/armv6 and i386/i386.

WITH_GCC
Set to build and install gcc and g++.

It is a default setting on arm/armeb, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32, pc98/i386, powerpc/powerpc, powerpc/powerpc64 and sparc64/sparc64.

WITHOUT_GCOV
Set to not build the gcov(1) tool.
WITHOUT_GDB
Set to not build gdb(1).
WITHOUT_GNU
Set to not build contributed GNU software as a part of the base system. This option can be useful if the system built must not contain any code covered by the GNU Public License due to legal reasons.
The option has no effect yet.
When set, it also enforces the following options:

  • WITHOUT_GNU_SUPPORT
WITHOUT_GNUCXX
Do not build the GNU C++ stack (g++, libstdc++). This is the default on platforms where clang is the system compiler.

It is a default setting on amd64/amd64, arm/arm, arm/armv6, i386/i386 and pc98/i386.

WITH_GNUCXX
Build the GNU C++ stack (g++, libstdc++). This is the default on platforms where gcc is the system compiler.

It is a default setting on arm/armeb, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32, powerpc/powerpc, powerpc/powerpc64 and sparc64/sparc64.

WITHOUT_GNU_SUPPORT
Set to build some programs without optional GNU support.
WITHOUT_GPIB
Set to not build GPIB bus support.
WITHOUT_GPIO
Set to not build gpioctl(8) as part of the base system.
WITH_GPL_DTC
Set to build the GPL'd version of the device tree compiler from elinux.org, instead of the BSD licensed one.
WITHOUT_GROFF
Set to not build groff(1) and vgrind(1). You should consider installing the textproc/groff port to not break man(1).
WITHOUT_GSSAPI
Set to not build libgssapi.
WITH_HESIOD
Set to build Hesiod support.
WITHOUT_HTML
Set to not build HTML docs.
WITHOUT_HYPERV
Set to not build or install HyperV utilities.

It is a default setting on arm/arm, arm/armeb, arm/armv6, ia64/ia64, mips/mipsel, mips/mips, mips/mips64el, mips/mips64, mips/mipsn32, powerpc/powerpc, powerpc/powerpc64 and sparc64/sparc64.

WITH_HYPERV
Set to build and install HyperV utilities.

It is a default setting on amd64/amd64, i386/i386 and pc98/i386.

WITHOUT_ICONV
Set to not build iconv as part of libc.
WITHOUT_INET
Set to not build programs and libraries related to IPv4 networking. When set, it also enforces the following options:

  • WITHOUT_INET_SUPPORT
WITHOUT_INET6
Set to not build programs and libraries related to IPv6 networking. When set, it also enforces the following options:

  • WITHOUT_INET6_SUPPORT
WITHOUT_INET6_SUPPORT
Set to build libraries, programs, and kernel modules without IPv6 support.
WITHOUT_INET_SUPPORT
Set to build libraries, programs, and kernel modules without IPv4 support.
WITHOUT_INFO
Set to not make or install info(5) files.
WITHOUT_INSTALLLIB
Set this if you do not want to install optional libraries. For example when creating a nanobsd(8) image.
WITH_INSTALL_AS_USER
Set to make install targets succeed for non-root users by installing files with owner and group attributes set to that of the user running the make(1) command. The user still has to set the DESTDIR variable to point to a directory where the user has write permissions.
WITHOUT_IPFILTER
Set to not build IP Filter package.
WITHOUT_IPFW
Set to not build IPFW tools.
WITHOUT_IPX
Set to not build programs and libraries related to IPX networking. When set, it also enforces the following options:

  • WITHOUT_IPX_SUPPORT
WITHOUT_IPX_SUPPORT
Set to build some programs without IPX support.
WITHOUT_JAIL
Set to not build tools for the support of jails; e.g., jail(8).
WITHOUT_KDUMP
Set to not build kdump(1) and truss(1).
WITHOUT_KERBEROS
Set this if you do not want to build Kerberos 5 (KTH Heimdal). When set, it also enforces the following options:

  • WITHOUT_KERBEROS_SUPPORT

When set, the following options are also in effect:

WITHOUT_GSSAPI
(unless WITH_GSSAPI is set explicitly)
WITHOUT_KERBEROS_SUPPORT
Set to build some programs without Kerberos support, like ssh(1), telnet(1), sshd(8), and telnetd(8).
WITHOUT_KERNEL_SYMBOLS
Set to not install kernel symbol files.
This option is recommended for those people who have small root partitions.
WITHOUT_KVM
Set to not build the libkvm library as a part of the base system.
The option has no effect yet.
When set, it also enforces the following options:

  • WITHOUT_KVM_SUPPORT
WITHOUT_KVM_SUPPORT
Set to build some programs without optional libkvm support.
WITHOUT_LDNS
Setting this variable will prevent the LDNS library from being built. When set, it also enforces the following options:

  • WITHOUT_LDNS_UTILS
  • WITHOUT_UNBOUND
WITHOUT_LDNS_UTILS
Setting this variable will prevent building the LDNS utilities drill(1) and host(1).
WITHOUT_LEGACY_CONSOLE
Set to not build programs that support a legacy PC console; e.g., kbdcontrol(8) and vidcontrol(8).
WITHOUT_LIB32
On amd64, set to not build 32-bit library set and a ld-elf32.so.1 runtime linker.
WITHOUT_LIBCPLUSPLUS
Set to avoid building libcxxrt and libc++.
WITHOUT_LIBPTHREAD
Set to not build the libpthread providing library, libthr. When set, it also enforces the following options:

  • WITHOUT_LIBTHR
WITHOUT_LIBTHR
Set to not build the libthr (1:1 threading) library.
WITH_LLDB
Set to build the LLDB debugger.
WITHOUT_LOCALES
Set to not build localization files; see locale(1).
WITHOUT_LOCATE
Set to not build locate(1) and related programs.
WITHOUT_LPR
Set to not build lpr(1) and related programs.
WITHOUT_LS_COLORS
Set to build ls(1) without support for colors to distinguish file types.
WITHOUT_MAIL
Set to not build any mail support (MUA or MTA). When set, it also enforces the following options:

  • WITHOUT_MAILWRAPPER
  • WITHOUT_SENDMAIL
WITHOUT_MAILWRAPPER
Set to not build the mailwrapper(8) MTA selector.
WITHOUT_MAKE
Set to not install make(1) and related support files.
WITHOUT_MAN
Set to not build manual pages. When set, the following options are also in effect:

WITHOUT_MAN_UTILS
(unless WITH_MAN_UTILS is set explicitly)
WITHOUT_MAN_UTILS
Set to not build utilities for manual pages, apropos(1), catman(1), makewhatis(1), man(1), whatis(1), manctl(8), and related support files.
WITH_NAND
Set to build the NAND Flash components.
WITHOUT_NCURSESW
Set to not build or depend on the libncursesw library.
WITHOUT_NDIS
Set to not build programs and libraries related to NDIS emulation support.
WITHOUT_NETCAT
Set to not build nc(1) utility.
WITHOUT_NETGRAPH
Set to not build applications to support netgraph(4). When set, it also enforces the following options:

  • WITHOUT_ATM
  • WITHOUT_BLUETOOTH
  • WITHOUT_NETGRAPH_SUPPORT
WITHOUT_NETGRAPH_SUPPORT
Set to build libraries, programs, and kernel modules without netgraph support.
WITHOUT_NIS
Set to not build NIS(8) support and related programs. If set, you might need to adopt your nsswitch.conf(5) and remove ‘nis’ entries.
WITHOUT_NLS
Set to not build NLS catalogs.
WITHOUT_NLS_CATALOGS
Set to not build NLS catalog support for csh(1).
WITHOUT_NMTREE
Set to install fmtree(8) as mtree(8). By default nmtree(8) is installed as mtree(8).
WITHOUT_NS_CACHING
Set to disable name caching in the nsswitch subsystem. The generic caching daemon, nscd(8), will not be built either if this option is set.
WITHOUT_NTP
Set to not build ntpd(8) and related programs.
WITH_OFED
Set to build the “OpenFabrics Enterprise Distribution” Infiniband software stack.
WITHOUT_OPENSSH
Set to not build OpenSSH.
WITH_OPENSSH_NONE_CIPHER
Set to include the "None" cipher support in OpenSSH and its libraries. Additional adjustments may need to be done to system configuration files, such as sshd_config(5), to enable this cipher. Please see /usr/src/crypto/openssh/README.hpn for full details.
WITHOUT_OPENSSL
Set to not build OpenSSL. When set, it also enforces the following options:

  • WITHOUT_KERBEROS
  • WITHOUT_KERBEROS_SUPPORT
  • WITHOUT_OPENSSH

When set, the following options are also in effect:

WITHOUT_GSSAPI
(unless WITH_GSSAPI is set explicitly)
WITHOUT_PAM
Set to not build PAM library and modules.
This option is deprecated and does nothing.
When set, it also enforces the following options:

  • WITHOUT_PAM_SUPPORT
WITHOUT_PAM_SUPPORT
Set to build some programs without PAM support, particularly ftpd(8) and ppp(8).
WITHOUT_PC_SYSINSTALL
Set to not build pc-sysinstall(8) and related programs.
WITHOUT_PF
Set to not build PF firewall package. When set, it also enforces the following options:

  • WITHOUT_AUTHPF
WITHOUT_PKGBOOTSTRAP
Set to not build pkg(7) bootstrap tool.
WITH_PKGTOOLS
Set to build pkg_add(8) and related programs.
WITHOUT_PMC
Set to not build pmccontrol(8) and related programs.
WITHOUT_PORTSNAP
Set to not build or install portsnap(8) and related files.
WITHOUT_PPP
Set to not build ppp(8) and related programs.
WITHOUT_PROFILE
Set to avoid compiling profiled libraries.
WITHOUT_QUOTAS
Set to not build quota(8) and related programs.
WITHOUT_RCMDS
Disable building of the BSD r-commands. This includes rlogin(1), rsh(1), etc.
WITHOUT_RCS
Set to not build rcs(1) and related utilities.
WITHOUT_RESCUE
Set to not build rescue(8).
WITHOUT_ROUTED
Set to not build routed(8) utility.
WITHOUT_SENDMAIL
Set to not build sendmail(8) and related programs.
WITHOUT_SETUID_LOGIN
Set this to disable the installation of login(1) as a set-user-ID root program.
WITHOUT_SHAREDOCS
Set to not build the 4.4BSD legacy docs.
WITH_SHARED_TOOLCHAIN
Set to build the toolchain binaries shared. The set includes cc(1), make(1) and necessary utilities like assembler, linker and library archive manager.
WITHOUT_SOURCELESS
Set to not build kernel modules that include sourceless code (either microcode or native code for host CPU). When set, it also enforces the following options:

  • WITHOUT_SOURCELESS_HOST
  • WITHOUT_SOURCELESS_UCODE
WITHOUT_SOURCELESS_HOST
Set to not build kernel modules that include sourceless native code for host CPU.
WITHOUT_SOURCELESS_UCODE
Set to not build kernel modules that include sourceless microcode.
WITHOUT_SSP
Set to not build world with propolice stack smashing protection.
WITH_SVN
Set to install svnlite(1) as svn(1).
WITHOUT_SVNLITE
Set to not build svnlite(1) and related programs.
WITHOUT_SYMVER
Set to disable symbol versioning when building shared libraries.
WITHOUT_SYSCONS
Set to not build syscons(4) support files such as keyboard maps, fonts, and screen output maps.
WITHOUT_SYSINSTALL
Set to not build sysinstall(8) and related programs.
WITHOUT_TCSH
Set to not build and install /bin/csh (which is tcsh(1)).
WITHOUT_TELNET
Set to not build telnet(8) and related programs.
WITH_TESTS
Set to install the FreeBSD Test Suite. See tests(7) for more details.
WITHOUT_TEXTPROC
Set to not build programs used for text processing. When set, it also enforces the following options:

  • WITHOUT_GROFF
WITHOUT_TOOLCHAIN
Set to not install programs used for program development, compilers, debuggers etc.
The option does not work for build targets.
When set, it also enforces the following options:

  • WITHOUT_BINUTILS
  • WITHOUT_CLANG
  • WITHOUT_CLANG_EXTRAS
  • WITHOUT_CLANG_FULL
  • WITHOUT_GCC
  • WITHOUT_GDB
WITHOUT_UNBOUND
Set to not build unbound(8) and related programs.
WITHOUT_USB
Set to not build USB-related programs and libraries.
WITH_USB_GADGET_EXAMPLES
Set to build USB gadget kernel modules.
WITHOUT_UTMPX
Set to not build user accounting tools such as last(1), users(1), who(1), ac(8), lastlogin(8) and utx(8).
WITHOUT_VT
Set to not build vt(4) support files (fonts and keymaps).
WITHOUT_WIRELESS
Set to not build programs used for 802.11 wireless networks; especially wpa_supplicant(8) and hostapd(8). When set, it also enforces the following options:

  • WITHOUT_WIRELESS_SUPPORT
WITHOUT_WIRELESS_SUPPORT
Set to build libraries, programs, and kernel modules without 802.11 wireless support.
WITHOUT_WPA_SUPPLICANT_EAPOL
Build wpa_supplicant(8) without support for the IEEE 802.1X protocol and without support for EAP-PEAP, EAP-TLS, EAP-LEAP, and EAP-TTLS protocols (usable only via 802.1X).
WITHOUT_ZFS
Set to not build ZFS file system.
WITHOUT_ZONEINFO
Set to not build the timezone database.

FILES

/etc/src.conf
/usr/share/mk/bsd.own.mk

HISTORY

The src.conf file appeared in FreeBSD 7.0.

AUTHORS

This manual page was autogenerated.
September 25, 2014 FreeBSD