|NSMB.CONF(5)||FreeBSD File Formats Manual||NSMB.CONF(5)|
NAMEnsmb.conf — configuration file for SMB requests
DESCRIPTIONThe nsmb.conf file contains information about the computers, users, and shares or mount points for the SMB network protocol.
The configuration hierarchy is made up of several sections, each section containing a few or several lines of parameters and their assigned values. Each of these sections must begin with a section name enclosed within square brackets, similar to:
The end of each section is marked by either the start of a new section, or by the abrupt ending of the file, commonly referred to as the EOF. Each section may contain zero or more parameters such as:
where key represents a parameter name, and value would be the parameter's assigned value.
The SMB library uses the following information for section names:
- [ SERVER]
- [ SERVER: USER]
- [ SERVER: USER: SHARE]
Possible keywords may include:
|A B C D|
|addr||- + - -||IP or IPX address of SMB server|
|charsets||- + + +||local:remote charset pair|
|nbns||+ + - -||address of NetBIOS name server (WINS)|
|nbscope||+ + - -||NetBIOS scope|
|nbtimeout||+ + - -||timeout for NetBIOS name servers|
|password||- - + +||plain text or simple encrypted password used to access the given share|
|retry_count||+ + - -||number of retries before connection is marked as broken|
|timeout||+ + - -||SMB request timeout|
|workgroup||+ + + +||workgroup name|
- The default remote mount-point configuration file.
- The user specific remote mount-point configuration file.
EXAMPLESWhat follows is a sample configuration file which may, or may not match your environment:
# Configuration file for example.com [default] workgroup=SALES # The 'FSERVER' is an NT server. [FSERVER] charsets=koi8-r:cp866 addr=fserv.example.com # User specific data for FSERVER [FSERVER:MYUSER] password=$$16144562c293a0314e6e1
All lines which begin with the ‘
#’ character are comments and will not be parsed. The “
default” section describes the default workgroup or domain, in this case “
SALES”. The next section depicted here as “
FSERVER”, defines a server section and then assigns it a charset which is only required when Cyrillic characters are not used. The hostname value, “
fserv.example.com”, is also assigned in this section. “
FSERVER:USER”, defines the user settings and is useful for saving the password used during a specific connection. The password may be plaintext or obfuscated using simple encryption. The simple encrypted password starts with the `$$1' symbols. Warning: the encryption function is very weak and intended only to hide clear text passwords. If the use of simple encryption is desired, the following command may be used on a password:
COMPATIBILITYAt the time of this writing, the IPX protocol remains unsupported. Future FreeBSD releases are expected to support this.
AUTHORSThis manual page was written by <osa@FreeBSD.org> and <trhodes@FreeBSD.org>.
|October 19, 2010||FreeBSD|