|NSCD.CONF(5)||FreeBSD File Formats Manual||NSCD.CONF(5)|
NAMEnscd.conf — nscd configuration file
DESCRIPTIONThe nscd.conf file is used by the nscd(8) daemon and is read on its startup. Its syntax is mostly similar to the nscd.conf syntax in Linux and Solaris. It has some differences, though — see them below.
Each line specifies either an attribute and a value, or an attribute, a cachename and a value. Usual cachenames are “
protocols” and “
rpc”. You can also use any other cachename (for example, if some third-party application uses nsswitch).
- threads [ value]
- Number of threads, which would listen for connections and process requests. The minimum is 1. The default value is 8.
- enable-cache [ cachename][ yes | no]
- Enables or disables the cache for specified cachename.
- positive-time-to-live [ cachename][ value]
- Sets the TTL (time-to-live) for the specified cache in seconds. Larger values can increase system's performance, but they also can affect the cache coherence. The default value is 3600.
- positive-policy [ cachename][ fifo | lru | lfu]
- The policy that is applied to erase some of the cache elements, when the size limit of the given cachename is exceeded. Possible policies are: fifo (first-in-first-out), lru (least-recently-used), and lfu (least-frequently-used). The default policy is lru.
- negative-time-to-live [ cachename][ value]
- The TTL of the negative cached elements in seconds. The larger values can significantly increase system performance in some environments (when dealing with files with UIDs, which are not in system databases, for example). This number should be kept low to avoid the cache coherence problems. The default value is 60.
- negative-policy [ cachename][ fifo | lru | lfu]
- The same as the positive-policy, but this one is applied to the negative elements of the given cachename. The default policy is fifo.
- negative-confidence-threshold [ cachename][ value]
- The number of times a query must have failed before the cache accepts that the element can not be found. At the default value of 1 each negative query result is cached and immediately returned from the cache on further queries. Higher numbers cause queries to be retried at the configured data sources the given number of times, before the negative result is returned from the cache on further queries. This allows to probe for the existence of an entry, and then to create it if it did not exist, without the negative probe result preventing access to the new entry for the duration of the negative TTL.
- suggested-size [ cachename][ value]
- This is the internal hash table size. The value should be a prime number for optimum performance. You should only change this value when the number of cached elements is significantly (5-10 times) greater than the default hash table size (257).
- keep-hot-count [ cachename][ value]
- The size limit of the cache with the given cachename. When it is exceeded, the policy will be applied. The default value is 2048.
- perform-actual-lookups [ cachename][ yes | no]
If enabled, the
nscd(8) does not simply receive and cache the NSS-requests results, but performs all the lookups by itself and only returns the responses. If this feature is enabled, then for the given
nscd(8) will act similarly to the NSCD.
NOTE: this feature is currently experimental — it supports only “
group” and “
NOTESYou can use the ‘
#’ symbol at the beginning of the line for comments.
BUGSPlease send bug reports and suggestions to <bushman@FreeBSD.org>.
|April 30, 2006||FreeBSD|