|NETWORKS(5)||FreeBSD File Formats Manual||NETWORKS(5)|
NAMEnetworks — network name data base
DESCRIPTIONThe networks file contains information regarding the known networks which comprise the DARPA Internet. For each network a single line should be present with the following information:
official network name network number aliases
Items are separated by any number of blanks and/or tab characters. A ``#'' indicates the beginning of a comment; characters up to the end of the line are not interpreted by routines which search the file. This file is normally created from the official network data base maintained at the Network Information Control Center (NIC), though local changes may be required to bring it up to date regarding unofficial aliases and/or unknown networks.
Network numbers may be specified in the conventional ``.'' (dot) notation using the inet_network(3) routine from the Internet address manipulation library, inet(3). Network names may contain any printable character other than a field delimiter, newline, or comment character.
- The networks file resides in /etc.
HISTORYThe networks file format appeared in 4.2BSD.
BUGSA name server should be used instead of a static file.
|June 5, 1993||FreeBSD|