|LINPROCFS(5)||FreeBSD File Formats Manual||LINPROCFS(5)|
NAMElinprocfs — Linux process file system
linproc /compat/linux/proc linprocfs rw 0 0
DESCRIPTIONThe Linux process file system, or linprocfs, emulates a subset of Linux' process file system and is required for the complete operation of some Linux binaries.
The linprocfs provides a two-level view of process space. At the highest level, processes themselves are named, according to their process ids in decimal, with no leading zeros. There is also a special node called self which always refers to the process making the lookup request.
Each node is a directory containing several files:
- A reference to the vnode from which the process text was read. This can be used to gain access to the process' symbol table, or to start another copy of the process.
- The complete virtual memory image of the process. Only those addresses which exist in the process can be accessed. Reads and writes to this file modify the process. Writes to the text segment remain private to the process.
Each node is owned by the process's user, and belongs to that user's primary group, except for the mem node, which belongs to the
- The normal mount point for the linprocfs.
- CPU vendor and model information in human-readable form.
- System memory information in human-readable form.
- A directory containing process information for process pid.
- A directory containing process information for the current process.
- The executable image for the current process.
- The complete virtual address space of the current process.
EXAMPLESTo mount a linprocfs file system on /compat/linux/proc:
mount -t linprocfs linproc /compat/linux/proc
HISTORYThe linprocfs first appeared in FreeBSD 4.0.
AUTHORSThe linprocfs was derived from procfs by . This manual page was written by , based on the procfs(5) manual page by .
|August 10, 1994||FreeBSD|