|BOOTPARAMS(5)||FreeBSD File Formats Manual||BOOTPARAMS(5)|
NAMEbootparams — boot parameter database
DESCRIPTIONThe bootparams file specifies the boot parameters that diskless(8) clients may request when booting over the network. Each client supported by this server must have an entry in the bootparams file containing the pathnames for its “root” and (optionally) “swap” areas.
Each line in the file (other than comment lines that begin with a ‘
#’) specifies the client name followed by the pathnames that the client may request by their logical names. The components of the line are delimited with blank or tab, and may be continued onto multiple lines with a backslash.
dummy root=host:/export/dummy/root \ swap=host:/export/dummy/swap \ dump=host:/export/dummy/swap
When the client named “dummy” requests the pathname for its logical “root” it will be given the pathname “ host:/export/dummy/root” as the response to its RPC request. The “host:” component must be supplied.
- default configuration file
|October 2, 1994||FreeBSD|