|AUDIT_CLASS(5)||FreeBSD File Formats Manual||AUDIT_CLASS(5)|
NAMEaudit_class — audit event class descriptions
DESCRIPTIONThe audit_class file contains descriptions of the auditable event classes on the system. Each auditable event is a member of an event class. Each line maps an audit event mask (bitmap) to a class and a description. Entries are of the form:
classmask: eventclass: description
Example entries in this file are:
0x00000000:no:invalid class 0x00000001:fr:file read 0x00000002:fw:file write 0x00000004:fa:file attribute access 0x00000080:pc:process 0xffffffff:all:all flags set
HISTORYThe OpenBSM implementation was created by McAfee Research, the security division of McAfee Inc., under contract to Apple Computer Inc. in 2004. It was subsequently adopted by the TrustedBSD Project as the foundation for the OpenBSM distribution.
AUTHORSThis software was created by McAfee Research, the security research division of McAfee, Inc., under contract to Apple Computer Inc. Additional authors include , , and SPARTA Inc.
The Basic Security Module (BSM) interface to audit records and audit event stream format were defined by Sun Microsystems.
|January 24, 2004||FreeBSD|