|ALIASES(5)||FreeBSD File Formats Manual||ALIASES(5)|
NAMEaliases - aliases file for sendmail
DESCRIPTIONThis file describes user ID aliases used by sendmail. The file resides in /etc/mail and is formatted as a series of lines of the form
- name: addr_1, addr_2, addr_3, . . .
The name is the name to alias, and the addr_n are the aliases for that name. addr_n can be another alias, a local username, a local filename, a command, an include file, or an external address.
- Local Username
- The username must be available via getpwnam(3).
- Local Filename
- Messages are appended to the file specified by the full pathname (starting with a slash (/))
- A command starts with a pipe symbol (|), it receives messages via standard input.
- Include File
- :include: /path/name
- The aliases in pathname are added to the aliases for name.
- E-Mail Address
- An e-mail address in RFC 822 format.
Lines beginning with white space are continuation lines. Another way to continue lines is by placing a backslash directly before a newline. Lines beginning with # are comments.
Aliasing occurs only on local names. Loops can not occur, since no message will be sent to any person more than once.
If an alias is found for name, sendmail then checks for an alias for owner-name. If it is found and the result of the lookup expands to a single address, the envelope sender address of the message is rewritten to that address. If it is found and the result expands to more than one address, the envelope sender address is changed to owner-name.
After aliasing has been done, local and valid recipients who have a ``.forward'' file in their home directory have messages forwarded to the list of users defined in that file.
This is only the raw data file; the actual aliasing information is placed into a binary format in the file /etc/mail/aliases.db using the program newaliases(1). A newaliases command should be executed each time the aliases file is changed for the change to take effect.
SEE ALSOnewaliases(1), dbm(3), dbopen(3), db_open(3), sendmail(8)
SENDMAIL Installation and Operation Guide.
SENDMAIL An Internetwork Mail Router.
BUGSIf you have compiled sendmail with DBM support instead of NEWDB, you may have encountered problems in dbm(3) restricting a single alias to about 1000 bytes of information. You can get longer aliases by ``chaining''; that is, make the last name in the alias be a dummy name which is a continuation alias.
HISTORYThe aliases file format appeared in 4.0BSD.
|$Date: 2013-11-22 20:51:55 $|