|VIAWD(4)||FreeBSD Kernel Interfaces Manual||VIAWD(4)|
NAMEviawd — device driver for VIA south bridge watchdog timer
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe viawd driver provides watchdog(4) support for the watchdog interrupt timer present on VIA south bridge chipset (VT8251, CX700, VX800, VX855, VX900).
The VIA south bridge have a built-in watchdog timer, which can be enabled and disabled by user's program and set between 1 to 1023 seconds.
The viawd driver when unloaded with running watchdog will reschedule the watchdog to 5 minutes.
HISTORYThe viawd driver first appeared in FreeBSD 10.0.
AUTHORSThe viawd driver and this manual page were written by <fabient@FreeBSD.org>.
|December 7, 2011||FreeBSD|