|USB_TEMPLATE(4)||FreeBSD Kernel Interfaces Manual||USB_TEMPLATE(4)|
NAMEusb_template — USB templates
SYNOPSISTo compile this module into the kernel, place the following line in your kernel configuration file:
To load the module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe usb_template module implements various USB templates that are needed when programming an USB device side driver. A USB template consists of an USB device descriptor, one or more USB configuration descriptors, one or more USB interface descriptors, one or more USB endpoint descriptors, USB strings and additional USB descriptors. The USB template module currently has templates for USB Mass Storage, USB CDC Ethernet and Message Transfer Protocol. USB templates are currently selected using the "hw.usb.template" sysctl. The "hw.usb.template" value can be changed at any time, but will not have any effect until the USB device has been re-enumerated.
STANDARDSThe usb_template module complies to the USB 1.0, 2.0 and 3.0 standard.
HISTORYThe usb_template module was written by <hselasky@FreeBSD.org>.
|March 18, 2014||FreeBSD|