|URTWN(4)||FreeBSD Kernel Interfaces Manual||URTWN(4)|
NAMEurtwn — Realtek RTL8188CU/RTL8188EU/RTL8192CU USB IEEE 802.11b/g/n wireless network device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
In both cases, place the following line in loader.conf(5) to acknowledge the firmware license (see below):
DESCRIPTIONThe urtwn driver supports USB 2.0 wireless network devices based on Realtek RTL8188CUS, RTL8188CE-VAU, RTL8188EUS, RTL8188RU and RTL8192CU chipsets.
The RTL8188CUS and RTL8188EUS are highly integrated 802.11n adapter that combine a MAC, a 1T1R capable baseband and an RF in a single chip. They operate in the 2GHz spectrum only. The RTL8188RU is a high-power variant of the RTL8188CUS. The RTL8188CE-VAU is a PCI Express Mini Card adapter that attaches to the USB interface.
The RTL8192CU is a highly integrated multiple-in, multiple-out (MIMO) 802.11n adapter that combines a MAC, a 2T2R capable baseband and an RF in a single chip. It operates in the 2GHz spectrum only.
This driver requires the firmware built with the urtwnfw module to work. For the loaded firmware to be enabled for use the license at /usr/share/doc/legal/realtek must be agreed by adding the following line to loader.conf(5):
- urtwn firmware license
HARDWAREThe urtwn driver supports Realtek RTL8188CU/RTL8188EU/RTL8192CU based USB IEEE 802.11b/g/n wireless network adapters, including:
- ASUS USB-N10 NANO
- Belkin F7D1102 Surf Wireless Micro
- D-Link DWA-125 rev D1
- D-Link DWA-131
- Edimax EW-7811Un
- Netgear WNA1000M
- Realtek RTL8192CU
- Realtek RTL8188CUS
- TP-LINK TL-WN723N v3
- TP-LINK TL-WN725N v2
EXAMPLESJoin an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev urtwn0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with network name “
ifconfig wlan create wlandev urtwn0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev urtwn0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
- urtwn%d: error %d, could not read firmware %s
- For some reason, the driver was unable to read the microcode file from the filesystem. The file might be missing or corrupted.
- urtwn%d: device timeout
- A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware. This should not happen.
SEE ALSOintro(4), netintro(4), urtwnfw(4), usb(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
HISTORYThe urtwn driver first appeared in OpenBSD 4.9 and FreeBSD 10.0.
AUTHORSThe urtwn driver was written by <firstname.lastname@example.org>.
CAVEATSThe urtwn driver does not support any of the 802.11n capabilities offered by the adapters.
|May 3, 2014||FreeBSD|