|URNDIS(4)||FreeBSD Kernel Interfaces Manual||URNDIS(4)|
NAMEurndis — USB Remote NDIS Ethernet device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe urndis driver provides Ethernet access over Remote NDIS (RNDIS), allowing mobile devices such as phones and tablets to provide network access. It is often referred to as USB tethering, and in most cases must be explicitly enabled on the device.
urndis should work with any USB RNDIS devices, such as those commonly found on Android devices. It does not support different media types or options. For more information on configuring this device, see ifconfig(8).
HISTORYThe urndis device driver first appeared in OpenBSD 4.7. The first FreeBSD release to include it was FreeBSD 9.3.
AUTHORSThe urndis driver was written by < firstname.lastname@example.org>, < email@example.com>, and < firstname.lastname@example.org>. It was ported to FreeBSD by < hps@FreeBSD.org>.
|April 21, 2014||FreeBSD|