|UMS(4)||FreeBSD Kernel Interfaces Manual||UMS(4)|
NAMEums — USB mouse driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe ums driver provides support for mice that attach to the USB port. Supported are mice with any number of buttons and mice with a wheel.
The /dev/ums0 device presents the mouse as a sysmouse or mousesystems type device. See moused(8) for an explanation of these mouse types.
- blocking device node
EXAMPLESUse the first USB mouse on the system as your console mouse:
moused -p /dev/ums0 -t auto
To be able to use the USB mouse under X, change the "Pointer" section in xorg.conf to the following:
If you want to be able to use the mouse in both virtual consoles as well as in X change it to:
AUTHORSThe ums driver was written by <firstname.lastname@example.org> for NetBSD and was adopted for FreeBSD by <email@example.com>.
This manual page was written by<n_hibma@FreeBSD.org> with input from <firstname.lastname@example.org>.
|November 27, 2006||FreeBSD|