|UMCT(4)||FreeBSD Kernel Interfaces Manual||UMCT(4)|
NAMEumct — Magic Control Technology USB-RS232 converter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe umct driver provides support for USB to RS-232 converters based on the Magic Control Technology USB-232 design. These devices support most of the standard RS-232 features including baud rates ranging from 300 to 115200 bits per second. However, neither hardware nor software flow control seems to be supported.
Access to devices under this driver is via the ucom(4) framework and device nodes.
HARDWAREThe umct driver supports the following adapters:
- Belkin F5U109
- Belkin F5U409
- D-Link DU-H3SP USB BAY Hub
- Magic Control Technology USB-232
- Sitecom USB-232
HISTORYThe umct driver appeared in FreeBSD 5.2. It is loosely based on the ubsa(4) driver by <kan@FreeBSD.org> with documentation from <email@example.com>.
AUTHORSThe umct driver was written by <scottl@FreeBSD.org>.
|November 20, 2011||FreeBSD|