|UART(4)||FreeBSD Kernel Interfaces Manual||UART(4)|
NAMEuart — driver for Universal Asynchronous Receiver/Transmitter (UART) devices
With flags encoded as:
- device is potential system console
- use this port for remote kernel debugging
- set RX FIFO trigger level to ``low'' (NS8250 only)
- set RX FIFO trigger level to ``medium low'' (NS8250 only)
- set RX FIFO trigger level to ``medium high'' (default, NS8250 only)
- set RX FIFO trigger level to ``high'' (NS8250 only)
DESCRIPTIONThe uart device driver provides support for various classes of UARTs implementing the EIA RS-232C (CCITT V.24) serial communications interface. Each such interface is controlled by a separate and independent instance of the uart driver. The primary support for devices that contain multiple serial interfaces or that contain other functionality besides one or more serial interfaces is provided by the puc(4), or scc(4) device drivers. However, the serial interfaces of those devices that are managed by the puc(4), or scc(4) driver are each independently controlled by the uart driver. As such, the puc(4), or scc(4) driver provides umbrella functionality for the uart driver and hides the complexities that are inherent when elementary components are packaged together.
The uart driver has a modular design to allow it to be used on differing hardware and for various purposes. In the following sections the components are discussed in detail. Options are described in the section that covers the component to which each option applies.
CORE COMPONENTAt the heart of the uart driver is the core component. It contains the bus attachments and the low-level interrupt handler.
HARDWARE DRIVERSThe core component and the kernel interfaces talk to the hardware through the hardware interface. This interface serves as an abstraction of the hardware and allows varying UARTs to be used for serial communications.
SYSTEM DEVICESSystem devices are UARTs that have a special purpose by way of hardware design or software setup. For example, Sun UltraSparc machines use UARTs as their keyboard interface. Such an UART cannot be used for general purpose communications. Likewise, when the kernel is configured for a serial console, the corresponding UART will in turn be a system device so that the kernel can output boot messages early on in the boot process.
KERNEL INTERFACESThe last but not least of the components is the kernel interface. This component ultimately determines how the UART is made visible to the kernel in particular and to users in general. The default kernel interface is the TTY interface. This allows the UART to be used for terminals, modems and serial line IP applications. System devices, with the notable exception of serial consoles, generally have specialized kernel interfaces.
HARDWAREThe uart driver supports the following classes of UARTs:
- NS8250: standard hardware based on the 8250, 16450, 16550, 16650, 16750 or the 16950 UARTs.
- SCC: serial communications controllers supported by the scc(4) device driver.
- for callin ports
corresponding callin initial-state and lock-state devices
- for callout ports
- corresponding callout initial-state and lock-state devices
HISTORYThe uart device driver first appeared in FreeBSD 5.2.
AUTHORSThe uart device driver and this manual page were written by <email@example.com>.
|March 12, 2008||FreeBSD|