|TX(4)||FreeBSD Kernel Interfaces Manual||TX(4)|
NAMEtx — SMC 83c17x Fast Ethernet device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe tx driver provides support for the Ethernet adapters based on the SMC 83c17x (EPIC) chips. These are mostly SMC 9432 series cards.
The tx driver supports the following media types (depending on card's capabilities):
- Enable autonegotiation (default).
- Set 100Mbps (Fast Ethernet) fiber optic operation.
- Set 100Mbps (Fast Ethernet) twisted pair operation.
- Set 10Mbps on 10baseT port.
- Set 10Mbps on 10base2 port.
The tx driver supports the following media options:
- Set full-duplex operation.
The tx driver supports oversized Ethernet packets (up to 1600 bytes). Refer to the ifconfig(8) man page on setting the interface's MTU.
The old “
ifconfig tx0 linkN” method of configuration is not supported.
- tx%d: device timeout %d packets
- The device stops responding. Device and driver reset follows this error.
- tx%d: PCI fatal error occurred (%s)
- One of following errors occurred: PCI Target Abort, PCI Master Abort, Data Parity Error or Address Parity Error. Device and driver reset follows this error.
- tx%d: cannot allocate mbuf header/cluster
- Cannot allocate memory for received packet. Packet thrown away.
- tx%d: can't stop %s DMA
- While resetting, the driver failed to stop the device correctly.
BUGSThe auto-negotiation does not work very well.
|July 16, 2005||FreeBSD|