|TWS(4)||FreeBSD Kernel Interfaces Manual||TWS(4)|
NAMEtws — 3ware 9750 SATA+SAS 6Gb/s RAID controller card driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe tws driver provides support for LSI's 3ware 9750 SATA+SAS 6Gb/s RAID controller cards.
These controllers feature the LSISAS2108 6Gb/s SAS RAID-on-Chip (ROC) and are available in 4- and 8-port configurations, supports RAID levels 0, 1, 5, 6, 10, 50 and single disk, with 96 SATA and/or SAS hard drives and SSDs.
For further hardware information, see http://www.lsi.com/.
HARDWAREThe tws driver supports the following SATA/SAS RAID controller:
- LSI's 3ware SAS 9750 series
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
- The maximum queued CAM SIM requests for one controller. The default value is 256.
- This tunable enables MSI support on the controller if set to a non-zero value. The default value is 0.
- The maximum queued requests for one controller.
- Limit the driver to use only 32-bit SG elements regardless whether the operating system is running in 64-bit mode. The default value is 0.
- array/logical disk interface
- management interface
DIAGNOSTICSWhenever the driver encounters a command failure, it prints out an error code in the format: “
ERROR: (<error source>: <error code>):”, followed by a text description of the error. There are other error messages and warnings that the driver prints out, depending on the kinds of errors that it encounters. If the driver is compiled with TWS_DEBUG defined, it prints out a whole bunch of debug messages.
AUTHORSThe tws driver was written by for LSI and this manual page was written by <delphij@FreeBSD.org> for iXsystems, Inc.
|October 4, 2011||FreeBSD|