|| FreeBSD Kernel Interfaces Manual
file system synchronizer kernel process
kernel process helps protect the integrity of disk volumes by flushing volatile cached file system data to disk.
The kernel places all vnode(9)'s in a number of queues. The syncer process works through the queues in a round-robin fashion, usually processing one queue per second. For each vnode(9) on that queue, the syncer process forces a write out to disk of its dirty buffers.
The usual delay between the time buffers are dirtied and the time they are synced is controlled by the following sysctl(8) tunable variables:
|| time to delay syncing files
|| time to delay syncing directories
|| time to delay syncing metadata
syncer process is a descendant of the ‘update’ command, which appeared in Version 6 AT&T UNIX, and was usually started by
/etc/rc when the system went multi-user. A kernel initiated ‘update’ process first appeared in
It is possible on some systems that a
occurring simultaneously with a crash may cause file system damage. See