|STG(4)||FreeBSD Kernel Interfaces Manual||STG(4)|
NAMEstg — driver for Future Domain based SCSI controllers
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
For one or more ISA cards:
For one or more PCI cards:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe stg driver provides support for ISA, PCCARD and PCI controllers based on Future Domain SCSI controller chips including the TMC-16C30, 16C50 and 32C60.
HARDWAREControllers supported by the stg driver include:
- Adaptec 2920/A
- Future Domain SCSI2GO
- Future Domain TMC-18XX/3260
- IBM SCSI PCMCIA Card
- ICM PSC-2401 SCSI
- MELCO IFC-SC
- RATOC REX-5536, REX-5536AM, REX-5536M, REX-9836A
Note that the Adaptec 2920C is supported by the ahc(4) driver.
HISTORYThe stg device driver has been developed for NetBSD/pc98 and ported for FreeBSD. It first appeared in FreeBSD 2.2 with PAO and merged in FreeBSD 4.2.
AUTHORSThe stg driver was written by .
|August 8, 2004||FreeBSD|