|SND_ES137X(4)||FreeBSD Kernel Interfaces Manual||SND_ES137X(4)|
NAMEsnd_es137x — Ensoniq AudioPCI ES137x bridge device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe snd_es137x bridge driver allows the generic audio driver sound(4) to attach to the Ensoniq 137x audio cards.
Runtime ConfigurationThe following sysctl(8) variables are available in addition to those available to all sound(4) devices:
- Controls the PCI latency timer setting. Increasing this value will solve most popping and crackling issues (especially on VIA motherboards).
- Enables S/PDIF output on the primary playback channel. This sysctl(8) variable is available only if the device is known to support S/PDIF output.
- Experimental polling mode, where the driver operates by querying the device state on each tick using callout(9). Polling is disabled by default. Do not enable it unless you are facing weird interrupt problems or if the device cannot generate interrupts at all.
HARDWAREThe snd_es137x driver supports the following sound cards:
- Creative CT5880-A
- Creative CT5880-C
- Creative CT5880-D
- Creative CT5880-E
- Creative SB AudioPCI CT4730
- Ensoniq AudioPCI ES1370
- Ensoniq AudioPCI ES1371-A
- Ensoniq AudioPCI ES1371-B
- Ensoniq AudioPCI ES1373-A
- Ensoniq AudioPCI ES1373-B
- Ensoniq AudioPCI ES1373-8
HISTORYThe snd_es137x device driver first appeared in FreeBSD 4.0.
AUTHORS<email@example.com> <cg@FreeBSD.org> <firstname.lastname@example.org>
|November 29, 2006||FreeBSD|