|SND_CSA(4)||FreeBSD Kernel Interfaces Manual||SND_CSA(4)|
NAMEsnd_csa — Crystal Semiconductor CS461x/462x/4280 PCI bridge device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe snd_csa bridge driver allows the generic audio driver sound(4) to attach to Crystal Semiconductor CS461x/462x/4280 based sound cards.
HARDWAREThe snd_csa driver supports the following sound cards:
- Crystal Semiconductor CS4280
- Crystal Semiconductor CS4610
- Crystal Semiconductor CS4611
- Crystal Semiconductor CS4614
- Crystal Semiconductor CS4615
- Crystal Semiconductor CS4622
- Crystal Semiconductor CS4624
- Crystal Semiconductor CS4630
- Genius Soundmaker 128 Value
- Hercules Game Theatre XP
- Turtle Beach Santa Cruz
Some onboard CS4610 chips are accompanied by the CS423x ISA codec instead of the CS4297 AC97 codec. Such configurations are not supported by the snd_csa driver yet.
HISTORYThe snd_csa device driver first appeared in FreeBSD 4.0.
|December 15, 2005||FreeBSD|