|SIMPLEBUS(4)||FreeBSD Kernel Interfaces Manual||SIMPLEBUS(4)|
NAMEsimplebus — ePAPR simple-bus driver
DESCRIPTIONThis bus driver is dedicated for the simple-bus node of a flattened device tree compliant with the ePAPR specification.
The simplebus entity does not represent any physical element by itself, it is rather an umbrella node grouping integrated on-chip peripherals like interrupt controller, connectivity controllers, accelerating engines and so on.
The driver is generic and common for all flattened device tree nodes claiming simple-bus compatibility. It iterates over direct descendants of the simple-bus node, instantiates newbus children and assigns resources to them, based on the configuration data retrieved from the nodes properties in fdt(4).
Note the simplebus does not manage device resources and passes through any requests to the fdtbus(4) layer.
STANDARDSPower.org Standard for Embedded Power Architecture Platform Requirements ( ePAPR).
HISTORYThe simplebus support first appeared in FreeBSD 9.0.
AUTHORSThe simplebus support was developed by Semihalf under sponsorship from the FreeBSD Foundation. This manual page was written by .
|July 12, 2010||FreeBSD|