|SIIS(4)||FreeBSD Kernel Interfaces Manual||SIIS(4)|
NAMEsiis — SiliconImage Serial ATA Host Controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The following tunables are settable from the loader(8):
- hint.siis. X .msi
- controls Message Signaled Interrupts (MSI) usage by the specified controller.
- hint.siisch. X .pm_level
controls SATA interface Power Management for the specified channel, allowing some power to be saved at the cost of additional command latency. Possible values:
- interface Power Management is disabled (default);
- device is allowed to initiate PM state change, host is passive.
Note that interface Power Management is not compatible with device presence detection. A manual bus reset is needed on device hot-plug.
- hint.siisch. X .sata_rev
- setting to nonzero value limits maximum SATA revision (speed). Values 1, 2 and 3 are respectively 1.5, 3 and 6Gbps.
DESCRIPTIONThis driver provides the CAM(4) subsystem with native access to the SATA ports of controller. Each SATA port is represented to CAM as a separate bus with 16 targets. Most of the bus-management details are handled by the SATA-specific transport of CAM. Connected ATA disks are handled by the ATA protocol disk peripheral driver ada(4). ATAPI devices are handled by the SCSI protocol peripheral drivers cd(4), da(4), sa(4), etc.
Driver features include support for Serial ATA and ATAPI devices, Port Multipliers (including FIS-based switching), hardware command queues (31 command per port), Native Command Queuing, SATA interface Power Management, device hot-plug and Message Signaled Interrupts.
The activity LEDs of the adapters supported by the siis driver can be controlled via the led(4) API for localization or status reporting purposes.
Same hardware is also supported by the atasiliconimage driver from ata(4) subsystem. If both drivers are loaded at the same time, this one will be given precedence as the more functional of the two.
HARDWAREThe siis driver supports the following controller chips:
- SiI3124 (PCI-X 133MHz/64bit, 4 ports)
- SiI3131 (PCIe 1.0 x1, 1 port)
- SiI3132 (PCIe 1.0 x1, 2 ports)
- SiI3531 (PCIe 1.0 x1, 1 port)
- identification LED device nodes
HISTORYThe siis driver first appeared in FreeBSD 8.0.
|April 8, 2011||FreeBSD|