|SGE(4)||FreeBSD Kernel Interfaces Manual||SGE(4)|
NAMEsge — Silicon Integrated Systems SiS190/191 Fast/Gigabit Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe sge device driver provides support for SiS190 Fast Ethernet controllers and SiS191 Fast/Gigabit Ethernet controllers.
All LOMs supported by the sge driver have TCP/UDP/IP checksum offload for transmit and receive, TCP segmentation offload (TSO), hardware VLAN tag stripping/insertion features. Due to lack of documentation Wake On Lan (WOL), Jumbo frame and an interrupt moderation mechanism are not supported yet.
The sge driver supports the following media types:
- Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5).
- Set 10Mbps operation.
- Set 100Mbps (Fast Ethernet) operation.
- Set 1000baseTX operation over twisted pair.
The sge driver supports the following media options:
- Force full duplex operation.
- Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
HARDWAREThe sge device driver provides support for the following Ethernet controllers:
- SiS190 Fast Ethernet controller
- SiS191 Fast/Gigabit Ethernet controller
HISTORYThe sge driver was written by <firstname.lastname@example.org>. And enhanced by <email@example.com>. It first appeared in FreeBSD 8.1.
|January 16, 2011||FreeBSD|