|SEM(4)||FreeBSD Kernel Interfaces Manual||SEM(4)|
NAMEsem — POSIX semaphores
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
To load the driver as a module at run-time, run the following command as root:
DESCRIPTIONThe sem facility provides system calls used by the standard C library ( libc) to implement POSIX semaphores. This facility offers support for such functions as sem_init() and sem_wait(). It is available both as a kernel option for static inclusion and as a dynamic kernel module.
SEE ALSOsem_destroy(3), sem_getvalue(3), sem_init(3), sem_open(3), sem_post(3), sem_wait(3), config(8), kldload(8), kldunload(8)
HISTORYThe sem facility appeared in FreeBSD 5.0.
|February 7, 2014||FreeBSD|